Coordinator

For Windows 7, 8, 8.1, and 10.

Version 5.6.7

Install

Click here for more information or installation options

* This version requires .net framework version 4.6 or later and the VC++ 14.0 runtime.  Installer will install the required components prior to installing the Coordinator program.

MedEDocs Coordinator